oauth login not working

I suppose the Asana team is actually doing some changes on their oauth / authentication procedure? Because, now, actually, it’s impossible to login.

The oauth procedure always crash, with messages like:
25 black bobcats pray fairly rudely
61 snobby turkeys skip fairly sadly
42 cold urchins krump quite poorly

On their web page.

I tought it could be only or app (bridge24.com).
So I tried another, (instagantt.com).
Same thing.
oauth not working for any app.

Hi @Frederic_Malenfant, I believe a fix is being worked on (if it’s not already live).

Thanks for reporting this, and sorry for the inconvenience.


Any news on this?
I’ve been trying to initiate OAuth flow for the first time, created my app with its client_id. I write the URL with the necessary parameters but it will always respond with a:
“invalid_request: The required parameter client_id is missing or invalid.”

I inspect the request sent and client_id is effectively being sent in the GET request with the same value that my Asana app has in the OAuth tab for client id.

Your bug is not related to the error I submit yesterday.
This one is fixed.
I think you have another issue.

A post was split to a new topic: Error authenticating to Microsoft Teams integration