Error creating webhook

Response Asana:
{“errors”:[{“message”:“The remote server did not respond within 10000 milliseconds.”,“help”:“For more information on API status codes and how to handle them, read the docs on errors: https://asana.com/developers/documentation/getting-started/errors”}]}

Response Server (PHP / Laravel):
public function confirm()
{
$key = Request::header(‘X-Hook-Secret’);

    // Valida key
    if ($key) {
        $response = FacadeResponse::make('', 200);
        $response->header('X-Hook-Secret', $key);
        $response->header('Content-Type', 'application/json');
        $response->header('Accept', 'application/json');
        $response->setProtocolVersion('1.1');
        $response->setStatusCode('200');

        return $response;
    }
}

Not completely sure but I believe Asana tried to handshake your server through another request and your server did not answer properly. @Phil_Seeman what do you think?

I can’t exactly tell from the info provided, and also I don’t know PHP so can’t comment on whether the exact construction of everything is correct - it looks like this is the confirmation handshake processing, though, and that it’s returning the X-Hook-Secret like it’s supposed to.

There is this issue, I wonder if this is a clue:

Per that post, it looks like @Wesley_Andrade_Soare is setting HTTP 1.1 but I don’t know if there are other aspects that are required as well?

Also cc’ing @Ross_Grambo (when he’s back from holiday), he’s the current reigning Webhook champion expert!

Thanks for the feedback, but the issue has not been resolved. Enter information in .htaccess unsuccessfully.
I am testing now with Postman and simplified the logic:
<?php
header('X-Hook-Secret: ’ . $_SERVER[‘HTTP_X_HOOK_SECRET’]);
header(‘HTTP/1.1 200 OK’);
echo ‘200 OK’;

@Wesley_Andrade_Soare, I private messaged you a debugging tool, let me know if that helps!