Add Subtask to bottom of list


Hoping someone can help. When adding a subtask via Zapier using a post webhook it adds the sub task to the top of the existing sub task list. Can you set a parameter so it goes to the bottom?

Please read this before posting

  • If you received an error from the API that you’re looking for help with, please include the error in your post and be descriptive of the requests you made that received the errors. To be clear, we need the error in the JSON response from the API, not the error your code raised.
  • Do not share any API credentials. Please check that the code you’re pasting into the post does not contain any real OAuth tokens or personal access tokens. If you have exposed credentials, you should revoke them immediately.


I believe you’ll need to do this in a separate call after you have added the subtask (in the wrong location initially):

Call Set the parent of a task with insert_before set to null.


Thank you! Very helpful. I tried it but does not change the order.

Maybe try null instead of "NULL"?

Thanks for the follow up. Still puts it on top of the sub task list.


Any suggestion here?

Also, I tried to test it myself quickly in the new API explorer but couldn’t see how to test in the right sidebar when one needs to remove a parameter. Is it possible to remove insert_after to test this quickly that way?



Figure it our with help of Asana support. The API call they gave me {{baseUrl}}/tasks/:task_gid/setParent needed work. The suggested to use the API call. But the default body in postman needed work. They also noted to use insert before and after. I just did after and it worked for what I needed.


Glad it’s working, @PMPro.

Support gave you the same API call that I did in the post above. I’m sorry I didn’t catch that you were not using the right call as I was focusing on the other part.

Greatly appreciate your help.

1 Like

I only just learned this myself, but if you delete all the characters in the field in the new API explorer in our docs, that will remove the field from the example payload. The text field has to be entirely empty and then it will be removed (as in JSON, you cannot have a dangling key, it must have some value).

1 Like

Correct. It does not seem to be a required field.

1 Like

That worked; thanks, @sasha_f! I was confused because the value I needed to supply was null (boldface, real value) and the value I made empty was appearing as null (not boldface), which worked perfectly once I read your explanation and understood.