'You do not have access to this pot.' error executing GetMultiplePorjects API on Node.js

Hello gurus,
I’m executing the sample code provided in the documentation in the GetMultipleProject API on NodeJs. I’ve added the Bearer token and the workspaceId, and removed the teams and offset attributes. I’ve installed the Asana library too.

When I run the code, I get the below error -

(base) navnn@Navs-MBP Asana % node app.js
errors: [
message: ‘You do not have access to this pot.’,
help: ‘For more information on API status codes and how to handle them, read the docs on errors: Errors

Does anyone know why this is happening and how to fix this?


Hi @Navaneeth_Kumar ,

Welcome to the forum! Could you post a code snippet (obscure your bearer token and any other personal info)?

Are you asking to return a very large data set? I just tried this myself for a team with ~500 projects and I got an error when I opted in for a ton of fields, but when I slimmed down to just a few fields, it ran ok. I saw in this forum post that there is a hidden (undocumented) data limit (even with the auto-pagination the library runs), so it could be that.

Hi @Navaneeth_Kumar ,

Sorry about the language in the error not being intuitive. It means you don’t have permission to access one of the projects you are trying to fetch. You’re using this method in the SDK?

You mentioned changing the workspace gid and removing the team gid from the sample code which I would expect to resolve this. Can you check to make sure there isn’t a typo in the workspace gid and that the sample team gid isn’t being sent?

Thanks for getting back, @John_Baldo . I can confirm that my workspace_gid is correct and I’ve removed the team gid. But still getting this error.

I have fixed the error now. I had to remove the opt_fields attribute that came with the sample code.

Thanks again

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.