webhook creations fails and also created webhooks stop working

Hi,

In a working installation, suddenly webhooks stop working, I’ve monitoring the port and there is no traffic.

Also I have tried to create a new webhooks and get as an answer:

b’{“errors”:[{“message”:“ETIMEOUT: Asana was unable to connect to your webhook within the timeout of 10000 ms.”,“help”:“undefined”}]}

But without traffic to our servers. I did some additional tests:

  • I’ve checked the DNS resolution around the world and it’s ok, and also the connectivity, also ok.
  • https certificates are OK.
  • I’ve also test to the url and it works.

So… I’m lost! Someone have an idea about what can happen and what can i test?

Hi @Manuel_Quinteiro :wave:t5:

In case it helps, you can find additional documentation on webhook here.

I’m also pinging @Ross_Grambo and @Joe_Trollo here to see if they can assist you with this issue!

Thank you!

Hello @Manuel_Quinteiro,

The best way I’ve found to debug this is to put a proxy in between to verify traffic. I prefer ngrok. I believe we did make a change recently that causes our SSL handshake to use a more standard set of ciphers, but I’d be surprised if this was causing the issue!

Let me know if when you test with a proxy, there’s still an issue. If so, I have a couple of debugging tools we can try.

Thanks,
Ross

If things are still not working, could you give me your gid, the resource gid, and any webhook gids you have?

Thanks Ross,

I’ve check everything, no traffic, I sniff all Network traffic, test all the certificates, but it is unnecessary because there are any traffic.

At the end I move the web hooks to the Google cloud functions that part of the server. I’ve created new whooks and deleted the old ones.

The only clue that I get is a time out registering new webhook.

It was a bit frustrating. A tool for test an URL or service cloud be very useful.

Kind regards

@Manuel_Quinteiro,

Could I get the id of the user setting up webhooks, and the id of one or more of the resources you’re trying to put webhooks on?

the same problem is happening to me, I’m doing the development, and as soon as the asana ends up receiving a few errors in a row, it stops sending the POST

Hey @Gustavo_Antunes,

If I understand you correctly, that is expected behavior. We try to deliver the webhook events and exponentially back off trying to send it if your server gives us error messages. See Error Handling and Retry in https://developers.asana.com/docs/webhooks.

@Manuel_Quinteiro,

We have a tool one of our engineers made a while ago to help debug handshake issues, but it’s only an mvp (and I can’t guarantee it still works :frowning: ) https://asana-webhook-tool.herokuapp.com/.

2 Likes