Unable to paste images from clipboard


Greetings! Asana just announced the ability to paste images from clipboard into comments. I am using Safari, but for some reason I can’t seem to get this to work.

My workflow is:
Find image I want to copy.
Right click, copy image
Go to Asana tasks.
Select comment box.
Command V, or right click, and paste.

Nothing happens though. I feel like I am missing something obvious. Any thoughts on what I am doing wrong here?


“Right click, copy image” so you are copying a file? And if you right click > copy an image from Safari for example?


At this time it looks like only images from within web browsers can be copied and pasted into task comments.


Hi @Spell

I just repeated what you described in Chrome and it worked perfectly. I’ve also pasted screenshots from the desktop, so the paste function isn’t limited to web-based files.

Have you tried it in Chrome instead? I know Asana tends to work best in Chrome.


Hi @Mark_Hudson - I just retested. I am able to copy an image into a task if the image is open, but not if I am copying the image shortcut. I too am using Chrome. Thanks!

Still cannot copy an image from within the body of an Outlook email into a task.


Thanks all for your reply! It is greatly appreciated. I tried it in Chrome which works perfectly, but not Safari. I have Asana permanently pinned in Safari so I thought perhaps it is because that. However, I have tried in a private Safari window, logged in, and it still does not work. I am using Safari Version 11.0.3 (13604.5.6) with MacOS High Sierra 10.13.3 (17D102). I will keep trying things to see if I can figure out if this is a bug, or something specific to my system.

Thanks again!


That’s odd. It works for me every time. I know the paste feature is quite new, so maybe it’s a bug. It might be worth contacting Asana support in case it’s a common issue.


Hi @Spell we have seen a few users having the same issue on Safari, and our team is currently looking into it! I’ll make sure to post an update as soon as I get an update from them! :slight_smile:


Just to update everyone, this bug has been squished. Seems to work fine now.


Thanks for keeping us posted @Spell! I’ll let the team know that the issue seems to be resolved for you!