Unable to connect to Google drive

Great news @Swen! If it works with a private window, the issue is probably related to an extension installed in on your browser, so if you have recently installed a new one, I’d recommend disabling it and see if it resolves your issue!

i was able to resolve the problem by following @Scott_Burns’ suggestion above. i am using Chromium 69.0.3497.100, so my settings might be slightly different than his build from August 2018, but i had to go to “Advanced Settings” -> Privacy and security -> Content settings -> Cookies . in the “Allow” section, i added:

[*.]google.com

1 Like

Sometimes it happens due to the caches or cookies so clear all cookies and caches also take help from Google drive server error if further face any difficulty related to the Google drive.

1 Like

Had the same issue here, followed the suggestion from @Scott_Burns worked like a dream! Thanks for that Scott!!

1 Like

Hey @Marie, I’m seeing the same error but it persists in an incognito window and another browser. Any ideas?

Hi @Jon_Yergatian and sorry for the trouble there!

You might be getting this error because of your browser currently not allowing 3rd party cookies.

Could you please try these steps in Chrome?

  1. At the top right, click the three stacked dots and then Settings.
  2. At the bottom, click Show advanced settings.
  3. In the “Privacy” section, click Content settings.
  4. Use the “Cookies” section to change your settings:
  5. To allow first-party and third-party cookies, choose Allow local data to be set.
  6. To block all cookies, choose Block sites from setting any data. When you use this setting, most sites that require you to sign in won’t work.
  7. To allow only first-party cookies and block all third-party cookies, check the box next to “Block third-party cookies and site data.” This setting means that site data cannot be written and read, even if you’ve added a site to the exceptions list and have chosen to allow its cookies.

This is also covered here: https://support.google.com/chrome/answer/95647?co=GENIE.Platform%3DDesktop&hl=en

Let me know how this works!

Same issue, ghostery somehow was blocking it. Only way to resolve was to pause ghostery, even whitelisting asana didn’t work for me.

Hey @Marie, I’ve attached a screenshot of my Chrome settings. Based on the documentation you provided, I would expect the Google Drive function to work but it does not.

Thanks for the quick follow-up @Jon_Yergatian!

Could you please try to log in from an incognito window? Are you running in the same trouble?

Yes, same problem in an incognito window.

Thanks for giving this a go and again, sorry for the trouble.

In order to investigate this further, I would recommend reaching to our support team with the info below:

Try to include the entire browser window, including URL bar, in the video screencast.

So sorry for not being able to help further via the Forum, but our support team should definitely be able to assist you resolve this issue!

same! had to pause ghostery

I know this topic hasn’t been active in a while, but just wanted to say that for me, it was Privacy Badger keeping this feature from working.

1 Like

Thanks for sharing @Luna and welcome to the Forum!

How to update Google play service on an Android device

Many times you may found some issues when you forgot to update your Google play app periodically. This is obvious that you need to update your Google Play services from time to time that keeps your applications on phone updated and error free.

In the future, if you still face an error, you are always free to visit Google Play Customer Service center or can visit http //g.co/recover that is available at every point of the time to offer actual guidance and assistance in a jiffy.

It worked for me as well, thanks !

1 Like

“Sorry, we were able to connect to Google. Please try again later.” problem at file attachment google drive is occurred for a while. It’s been almost a year, but it hasn’t been resolved. Of course, I had followed chrome cookie settings guide from this thread. It seems to be a special case that only happens in this environment (mac OS X + chrome). In all my other environments, it works well, but it’s still not on Mac & Chrome.

This solution still works! Thanks Scott!

Briefly describe (1-2 sentences) the Bug you’re experiencing:

Steps to reproduce: Trying to attach google slide to a task … keep getting an error message once I click on file. Google drive is same email that my asana is set up with.

Browser version: Google Chrome.

Upload screenshots below:
Screen Shot 2020-03-23 at 11.31.29 AM

Hi @Shaun_Pezman, this isn’t a bug but a setting issue, have a look at this post, it should help you resolve the issue!