Template tasks showing for users

template
#21

I’ve been creating Custom Templates for our business and assigning tasks and subtasks to users. The problem is that when I create the template the tasks are showing up in “My Tasks” for all users. Is there a way to assign users in a template and have them not show up in “My Tasks” until a project is created using that template?

#22

I believe the answer to this is no. A template is a project and many have brought up this issue. I have suggested that you use a tag for the Assignee in the template as a holder and then when the template is actually activated use access the tag (name of assignee) and do a multi task select to add the person to the Assignee filed. This possible could be done in a similar manner with a custom field.

1 Like
#23

This has been indeed an issue for a lot of people, I flagged your question so the moderation team can merge it into the existing thread.

2 Likes
#24

Hi @Arthur_King, this is a great question and, as @Bastien_Siebman said, we already have a tread on this topic with more information about this feature request. I have gone ahead and merged your post with Template tasks showing for users. Please don’t forget to vote to contribute to this feature request. Let me know if you have any questions :wink:

2 Likes
#25

I feel an enhancement here is very important, at least an option to suppress task notifications in templates. In our workflow, we have a template projects with many, many tasks in them, and it is confusing and distracting for users to have those tasks and deadlines show up in their task list, when it’s not from an actionable project, but rather just the template.

With the recent feature of adding relative dates to templates, having deadlines and assignees in templates makes so much sense. Except for this issue — which makes working with templates confusing.

I am aware of using the Later attribute to hide tasks in My Tasks, but it’s a pain to communicate that to everyone every time a template is created. It’s kind of a hack.