Subtasks not showing up in search results with custom field (dropdown) modifier "with no value".

Briefly describe (1-2 sentences) the Bug you’re experiencing:
When using an advanced search with a custom field set to “with no value”, subtasks won’t show up in the search results. Only tasks.

Not sure if this is a related bug or intended behavior, but something similar happens with the custom field (dropdown) set to “is not” (with any option chosen). Subtasks with no option chosen won’t show up while tasks will.

Steps to reproduce:

  • Add a custom field (dropdown) to your project.
  • Create a task and subtask with the custom field. Don’t select an option, leave the field empty.
  • Create an advanced search and include the new custom field.
  • Set the custom field to “with no value” and set the custom field of the task and subtask accordingly so that they should show up and hit go.
  • All that will show up is the task, the subtask won’t.

Browser version:
Google Chrome Version 80.0.3987.122
Safari Version 13.0.4 (14608.4.9.1.4)

Upload screenshots below:

Thank you for taking time to report this behaviour @Nicolas_Fischer.

I’m filing a task for the Team to get more information about this and I’ll keep you posted as soon as I get an update from them.

Thank you for your help! Have a great weekend!

1 Like

Hey @Natalia ,

can you give us any info about the timeline here? I assume I shouldn’t expect this to be fixed in the next couple of weeks/months?

We can’t just wait this out, we have to change our custom fields, templates and workflows to accommodate for this bug.

Thanks!

Edit: Also, has this thread been moved to tips and tricks? Why?

Sincere apologies for the delay in responding @Nicolas_Fischer

I got an update from our Team who has acknowledge this issue and they are currently working to prioritise it. Unfortunately I don’t have a precise timeline but hopefully I’ll have some more information to share shortly.

Again, apologies for the inconvenience this is causing you and thank you very much for your patience!

2 Likes

Just commenting to second the fact that subtasks are not showing up in searches despite specifically selecting the field for subtasks. I have a custom search saved to find tasks that have been assigned to each of my team members but that are not in a specific project. Subtasks aren’t showing up like they used to, which is causing us to miss tasks and drop the ball. Please fix.