sometimes multiple simultaneous rules don't work

Briefly describe (1-2 sentences) the Bug you’re experiencing: When asana triggers two rules (multiple rules), sometimes one rule works but other one doesn’t work.
I attached gif example. So please check it.

Steps to reproduce: I made custom field named “Review”.
When a reviewer switch review to “approved” two rules trigger.

  1. If review field switch to “Approved”, the task switch to “Completed”
  2. If review field switch to “Approved”, the task move to Done section

Sometimes one side rule doesn’t work.
But, sometimes one side rule works a little late.

Browser version: 77.0.3865.120
https://gyazo.com/252783c93916b9de352e4bb7376ac3d4

Upload screenshots below: https://gyazo.com/8afe679ed771ccf345d6dfce6d848c67
I’m sorry, my language is Japanese.
Explanation of the custom field “Review”

  • “レビュー待ち” means waiting review
  • “レビュー中” means reviewing
  • “再提出” means try again
  • “合格” means approved

Welcome to the Forum @sune and thank you for taking time to report this and for the screencast. It is very helpful.

I have tried to reproduce this on my end by creating the same rules you have explained and it seems to work fine for me. I’m going to file a task for the Team to investigate it. In order to provide them with more information, could you please provide the URL of the Project where you have these rules set up?

Looking forward to your reply!

Natalia, Thank you for reply and trying to reproduce that.
here is the asana project: https://app.asana.com/0/1146994983830024/board

I also tried again, and I found that syncing or rendering was delayed.

I wrote that “Sometimes one side rule doesn’t work.
But, sometimes one side rule works a little late.”
Probably, “Sometimes one side rule doesn’t work” is just “delaying”

Thank you for your prompt response @sune and for the additional information.

What about trying to set up a different workaround to see if it works better? What if you set these two rules:

Rule 1: If review field switch to “Approved”, the task switch to “Complete
Rule 2: If task is marked Complete, move it to the Done Section

Looking forward to your reply!

P.S.: I’m moving this thread to the #tipsandtricks category since we have confirmed it’s not a Bug. I hope it’s OK :slight_smile:

Natalia, thank you for suggesting a solution.
Actually, I’ve already tried the solution though, it doesn’t work.

Rules are just triggered, when a client user operate asana UI.
Namely, chained automation doesn’t work.
I think that is correct behavior for asana, because if chained automation works, all rules cause malfunction for user.

I agree with you!

P.S.: I’m moving this thread to the #tipsandtricks category since we have confirmed it’s not a Bug. I hope it’s OK :slight_smile:

I think the rendering delay doesn’t matter for me.

You are completely right @sune . Chained automation is not available but it completely slipped out of my mind when trying to assist you better here :see_no_evil: Apologies for that!

Your set up was definitely the correct one :clap::clap::clap:

I’ve gone ahead and marked your solution as resolved. Please, let me know if you encounter another issue regarding this and I’ll be more than happy to help you further!

Have a great day! :slight_smile:

2 Likes