Slack Bot Task Link Wrong

Briefly describe (1-2 sentences) the Bug you’re experiencing: when I get notifications in Slack about asana updates, the URL is incorrect. When I follow the URL, I get this message in Chrome: ’ It looks like you don’t have access to this’ but I can find it via the web portal.

Note - I am a member of 2 asana groups, only 1 of which I actually get notifications for.

Steps to reproduce:
Update a task in Asana, wait for update to get to Slack, click on the link and when it opens I get an access error.

Browser version: n/a

Upload screenshots below:
image

We are also experiencing this right now. Looks like I can still like and comment but can’t link from Slack into Asana. We are getting the same error message.

Hi @Tyler_Parmelee and thanks for the report.

You mentioned you’re a member of 2 Asana’s space, can you confirm you’re logged into the right space?

Could also share the URL of this task?

Thank you!

@Marie
Yes, I am logged into the correct space (it is the one that shows up when I go to the web portal).

The one that gets sent to me in slack is this: https://app.asana.com/0/0/1193311592065057/f
but this is the link when I navigate from the web portal: https://app.asana.com/0/1102692436255672/1193311592065057/f

I confirmed that in slack the bot’s default domain is set to the correct one via /asana settings

Thanks!

I created a separate thread for what appears to be related issue. You can read that here: Broken links; Seems project id is now required

This seems to be fixed. It’s working fine now.

This seems to be fixed. Working correctly now.

Briefly describe (1-2 sentences) the Bug you’re experiencing:
Previously you could use urls in the format of https://app.asana.com/{BOARD_ID}/{TASK_ID} where BOARD_ID was 0. The resulting URL would be https://app.asana.com/0/{TASK_ID}.

This previously worked, but no longer does. It seems that the BOARD_ID is required. When accessing a previous url with BOARD_ID of 0, you now get an authorization error.

Side note: if you move the task to another project would the URL redirect to new board automatically?

Steps to reproduce:

  • Create a task in Asana
  • Copy URL of task
  • Paste task and replace BOARD_ID with 0
  • Authorization error

Browser version:
Chrome, but shouldn’t matter.

Upload screenshots below:

1 Like

@MarkB and @Tyler_Parmelee,

The issue seems to be resolved for @karlog, can you confirm it is resolved for you too?

@Marie it looks like it has been resolved. Thanks you!

1 Like

This topic was automatically closed 16 days after the last reply. New replies are no longer allowed.