"Show less" tab on Calendar showing on the wrong date

The tab

Steps to reproduce: have a date (T) with >4 tasks showing so that “Show less” line is visible. Move some of the tasks to T+1 so that there are >4 tasks on T+1 and <=4 tasks on T. The “Show less” line will still be on T, not T+1 as one would expect

Browser version: Chrome 78.0.3904.108 64-bit

Upload screenshots below:asana_bug

Hi @Artem_Voit and welcome to the Forum!

Thank you for taking time to report this. I’m filing a task for the Team to understand the behaviour of the “Show less” option and I’ll get back to you as soon as I have more information about it.

Thank you again! Have a great Thursday!