Rules with Date Range: Ability to move tasks out of view until they are scheduled to start

It boggles my mind that Rules trigger on the End Date when there’s a range.
I have a need to move tasks out of view until they are scheduled to start.
I’ve been in contact with Customer Support and they say it’s functioning as designed because rules are triggered by Due Dates.

To me, it seems ludicrous :frowning:

1 Like

Hey @Jeff_Bantz

you might want to vote for this existing thread as well :slight_smile: My Tasks Changes: Rules: Date Range For Rule

And this might be the solution you are looking for? New triggers for Rules: “Due date is approaching” and “Task is Overdue” (only available for Business and Enterprise though, not sure what plan you are on)

1 Like

Thanks - I upvoted it and added a comment.
The problem I’m having is best described as this.
Task A is going to take 5 days to work on…and I’ve got it set up to start working on it 5 days before the due date. I don’t need to see it until it’s time to start working on it.

So, if my start date is 9/6/2021 and my end date (due date) is 9/10/2021 I want it to pop into my “Today” view using my existing rule on 9/6 instead of 9/10.


Yeah makes complete sense!

Jeff, I suspect 99+% of Asana users agree with you. It’s just the Asana architects who seemingly don’t.

Hi @Jeff_Bantz,

You might want to check out our Flowsana integration, which does allow you to create a date-based rule trigger based on start date.

@Jeff_Bantz and @Andrea_Mayer,

Isn’t it this post that you want to vote on that matches this thread’s need?:




Hey @lpb,

yes perfect seems like exactly what @Jeff_Bantz is looking for.

1 Like

Updated and hopefully they’ll see the rationale!


This is completely ridiculous. Tasks used to move into the ‘Today’ category automatically based on their start dates, not their due dates. When you change a basic function like this you complete throw off the reliability that was once built into this product. Furthermore, when you don’t allow users to make a ‘rule’ to compensate for this, you’ve ‘disabled’ the product - why?

1 Like