Rich preview is not showing - Salesforce

We have a flow connected to a button in Salesforce. It creates Asana tasks. I have enabled rich preview in the flow and it’s working when admins use the button, but it’s not working for the custom profiles. How can I solve this?

I mean the rich preview is not appearing when custom profiles are using it.

Hi @Zeynep_Samiloglu, sorry to hear that you’re running into trouble here!

Could you please try the troubleshooting steps listed below and let me know if any of these resolve the issue?

Looking forward to hearing back from you! :slight_smile:

1 Like

Hi @Rebecca_McGrath , thank you for your reply. I did the steps but it didn’t work. Also I noticed something else. When the custom profile uses the button, the flow is creating the task in Asana but not connecting it to the record in Salesforce, whereas when admins use it, it shows up in the Asana tasks section:

We got an error email:

Sandbox

Apex script unhandled exception by user/organization: 0055w00000DtpVn/00D7e00000GL6dR Source organization: 00D5w000006UoSH (null) Failed to invoke future method ‘public static void createCustom(Map<String,String>)’ on class ‘AsanaPublic.AsanaTask’ for job id ‘7077e00002OYRYd’

caused by: AsanaPublic.AsanaTask.TaskDuplicationException: Cannot create Task. Error:[{“message”:“sObject type ‘Layout’ is not supported.”,“errorCode”:“INVALID_TYPE”}]

Class.AsanaPublic.AsanaTask: line 532, column 1

We don’t get this error when the admins use the button. Do you know what’s causing this?
Thanks!

Thanks for getting back to me, @Zeynep_Samiloglu!

Are you able to give users the “Author Apex” setting and see if the issue still persists?

If that doesn’t work, we encourage to have the API Enabled flag​

  • Have created test user
  • Have assigned Custom: Sales Profile
  • Have checked API Enabled flag is turned on (Profile → System Permissions)
  • Object details previews are getting created

Hope this helps! Keep me posted!

Hi @Rebecca_McGrath,
I tried Author Apex permission and it worked, but unfortunately we can’t give our users Setup & Config permission.

We already have API Enabled flag in the custom profile and the profile has view & edit access on the fields included in the flow. The task is still getting created without rich preview and not getting attached to the record in SF. Any other permissions do you feel like I should check?

Thanks!

Hi @Zeynep_Samiloglu, thanks for getting back to me!

From here, I would suggest reaching out to our Support team as they have access to additional tools that we don’t have here on the Community team to be able to assist you best.

You can contact them by following the steps below:

I hope this helps! :slight_smile:

Thanks! I’ll reach out to them :slight_smile:

1 Like

This topic was automatically closed 16 days after the last reply. New replies are no longer allowed.