Refreshing Reports

I notice that when I update a task that appears in a Report, the Report is not refreshed. In other words, if the report filters out completed tasks, and then I mark a task as completed, it remains in the report. Is there a way to force a refresh of the report after editing a task? Currently, I press Refine Search and then Save to have it refresh, but wondering if there is a better way.

Hi David,

If you have saved your advanced reports the search results should always automatically up date. I would double check your parameters in the search to make sure that you are filtering for what you truly want to track (i.e. making sure that you are filtering for only incomplete tasks).

Once you have double checked your parameters and it’s still not updating correctly I would consider submitting a bug report.

I hope this helps.



A similar topic exists and has found a solution, maybe you can give a glance to it:

1 Like

Hi @DavidWS,

This often happens when the report include a specific date as opposed to a length of time; for example if you you look for all tasks from Sunday 28th of May, your report will always capture tasks with a due date on this specific date; while if you use the combination “Tasks” with a due date on “Yesterday” , you report will give you these task for yesterday (=Sunday 28th of May) but will update overtime.

And as @Julien_RENAUD mentioned, you can also take a look at this other thread: Refresh report / search option

Let us know if you have any follow-up questions :slight_smile: