Recurring Tasks not appearing in My Task view

I currently have several projects with recurring tasks. However, once I complete the task, the next task does not appear on the My Tasks view. The task is correctly assigned to me in the task in the Project. The task will only appear on My Tasks if I unassign and then reassign the task to myself.

The task only doesn’t appear on List view, but does appear on Calendar view.

@kylie.walsh, Is there any chance it’s hidden in your collapsed Later section? Try this:

  • In My Tasks Calendar view where you say you can see the task, click on it and then do Tab+Y (Mark for Today).
  • Click the List tab
  • Does your task appear in the Today section now?

Perhaps that might help, or maybe I’ve guessed incorrectly,

Larry

Hi Larry,

Thanks for the quick reply! They were hidden under the Upcoming section. Is there anyway to keep them from populating there? None of my other tasks have ever done that before - they always appear under Recently Assigned.

Glad you found them! I’m afraid I don’t think there’s a way to get them to appear in Recently Assigned. (There’s a My Profile Settings > Hacks option that makes them appear in Later rather than Upcoming, but that’s even worse for you, probably.) Upcoming tasks will auto-promote to Today at midnight before their due date, so perhaps that could allow you to leave them there? I think that generates a Notification when that happens too. Otherwise you’d need to remember to manage manually.

1 Like