Problem linking Slack and Asana

I am currently trying to use Asana in Slack.
Each time I am doing a command line I receive this message:
Hi @Brigitte, we recently released a new Asana for Slack app. To get the latest improvements to your Asana for Slack experience, please authorize Asana.
Learn more
With Button to Connect Asana to Slack
I then click on the button and get the message in my browser that Asana is already install.
I then click continue on this message and it tell me that I connect it successfully and to wait for a message in Slack. I never received this message and the connection isn’t working for me.
My boss install asana application in our slack team and it is working for him.

2 Likes

I’m facing the same problem. Any fixes?

Me too. Doesn’t seem to be a response as yet?

Same problem here. Does anyone have a solution?

I looked around and cannot figure out how to fix this. It works with everyone else in my company.

So I did some digging…

I created another user with a test account and followed the Connect Asana to Slack flow from this fresh account.

Clicking the link in Slack goes to here:

https://slack.com/oauth/authorize?client_id=xxxxxxxxx.xxxxxxxxx0&scope=&state=&team=XXXXXXXX

Then there is a redirect to here which is the missing dialog in your flow:

https://app.asana.com/-/oauth_authorize?client_id=xxxxxxxx&redirect_uri=https://slack-server.asana.plus/auth/asana&response_type=code&state=xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx

If I load this dialog in my real Slack account I get to the approve screen. However if I click Approve I get the following error:

Request is missing required cookie ‘integrationUserId’

I manually added this cookie using my test account integrationUserId cookie and I get an internal server error.

Now the app shows up in my Asana profile settings though.

However it still doesn’t work.