Power BI stuck on "Preview is evaluating..."


I’ve recently upgraded to a Business trial because I’d like to integrate Asana tasks (and comments?) into Power BI dashboards that I’ve created. However, no matter what I try, I get this message and cannot go any further.

If I just press OK then I get the table loaded into PBI, but then if I click on the “Table” navigation inside Edit Query, I get essentially the same, never-ending wait for it to process the information.

The list I’m trying to load only has around 30-40 items. Any advice?

This is also happening when I try and load from a project that has 1 task in it…

I assumed this would be a thriving, busy community where after over 30 views, someone from Asana may be in touch to offer some assistance?

Hi @Ant_Mitchell

I am in no way an expert on Power Bi, but I figured I would try to help here.

Have you reviewed the requirements for Power Bi and Asana for this integration? I have the Asana requirements attached, but not sure if Power Bi has their own instructions for this integration.

@ambforumleader and @pforumleader any advice here?


Hi. Yes I met all the criteria, it just wasn’t working.

However, maybe it just needed time to permeate the change to trial business account in order to work, because after leaving it alone for a few days I’ve just tried again…and it’s working.

No comment data though, which is what I suspected and in reality, what I was most looking for extracting without having to write code to extract them (I’ve already had to write over 300 UPs in SQL for one system)…unless anyone has any suggestions of extract tools that DO include comments?



Hello @Ant_Mitchell
Glad one aspect of it is working already.
I am not an expert either in this field. I suggest contact asana support for guidance if the comments should have been reflected in your dashboard but they aren’t.

I added the group here if anyone can assist @pforumleader @ambforumleader

Thanks for your help here @Mike_Tammaro and @Rashad_Issa! and sorry for the trouble @Ant_Mitchell!

If you meet all the requirements for installation and the issue persists, I also recommend you to contact our support team, so we can investigate the issue further: How to contact our Support Team ✉

When you contact them, please send them the URL of this project so you don’t need to confirm this information again!

I hope the issue is solved soon. Let us know if you have any other questions :slight_smile:


This topic was automatically closed after 3 days. New replies are no longer allowed.