Link to project in different workspace not working in Android app

Briefly describe (1-2 sentences) the Bug you’re experiencing:
In the Android app, when clicking a link to a project in a different workspace, the app is “Loading…” indefinitely.
The same link works in a browser.

Steps to reproduce:

  1. Copy a link to a project.
  2. Paste it in a description of another project in a different workspace.
  3. Open project 2 in the Android app and click the link.

Browser version:
Android app

Upload screenshots below:

Hi @royf and welcome to the Forum!

I just tried to reproduce this issue on Android and was able to open a project nested in Org A, from Org B, just by clicking on the project URL.

Before I escalate this issue further, could you please confirm the info below:

  1. Have you tried to reinstall your Asana app?
  2. Is your application up to date?
  3. Could you let us know what version of Android you’re using?
  4. What happens after you click on the project link; are you seeing an error message? Could you send us a screenshot maybe?

Looking forward to your reply; have a great Monday!

1+2. I’ve only recently installed the app, so it’s up to date.
I’m using version 6.24.4, updated on 21 May 2019.

  1. I’m using Android version 8.0.0.

  2. As I said, when I click the project link I’m seeing a dialog saying “Loading…” with a rotating circle.
    It stays until I cancel, e.g. by clicking outside of it.

Just to make sure, I created a new workspace, a project in it, and copied the new project’s link to a project description in my existing workspace — for the same result described in (4) above.

Got you @royf, thank you so much for sharing additional information!

I’ve gone ahead and filed a bug for our Mobile Team to investigate. I’ll be in touch if we need more info or as soon as I have an update on my end! Thank you so much for taking the time to report this issue!

I’ve updated the app to version 6.25.1 and the problem seems fixed.

1 Like

Hi @royf and thanks for the follow-up! I just tried on the latest update available and it’s seems to be working for me too, so marking this one resolved!

This issue returned in version 6.28.5 of the android app.

Hi @royf :wave: . Sorry to hear that you are running into this issue again.

Are you experiencing the same "Loading " issue or receiving an error message?

Looking forward to your reply!

No, this time the app shows “Loading” and then crashes.
This is still an issue in version 6.28.7.

HI @royf :wave: Thank you for the follow-up

I’ve updated this bug for our Team to investigate it further. I’ll be in touch as soon as I have more information about it!

Thank you for your patience!

Hi @royf :wave:

Just a quick note to let you know that our team has pushed a fix for this and it will be out in the next version (6.30) that will be out in about 1 week.

Thanks again for the report and for your patience! As always, let us know if you have any follow-up questions!