Importing apostrophes into task descriptions

Hi all!

I’ve noticed that when I import a csv that contains apostrophes in a field mapping to the description field in Asana, they get picked up as errors and show up as “’” instead. So far I’ve tried these things to see if it fixes it:

  • Editing the cell’s format in an excel to be text instead of general before exporting as a csv and then importing into Asana
  • Creating the csv as an export from Google sheets first instead of from Excel
  • Importing as a plain csv vs. csv utf-8
  • Changing the Asana character encoding option between utf-8 and Windows

Any other suggestions? Or have any folks that have run into this as well?

Thanks in advance!

2 Likes

Hi @Taylor_Cohen, let me check with our team if we have a workaround for this. With the holidays they could be a little longer to get back to me, but I’ll be in touch as soon as I’ve an update!

1 Like

Also, I just noticed that my description of what happens didn’t show up in my post, I guess because it’s a coding thing. This is what happens without the spaces - & # x 2 7 ;

Hi @Marie, just checking in on the progress of this. Completely understand the holidays causing delays, just let me know there’s a relative timeline I can expect for this. Thanks so much for your help!

1 Like

Thanks for your patience @Taylor_Cohen, I’ve pinged the bug I filed on your behalf and requested an update from our team. I’ll be in touch as soon as they get back to me!

1 Like

Hi @Marie, just checking. Any updates on this? Sorry to keep pinging this, we’re just pausing a big import related to this issue until we figure it out. However, it’s unlikely we’ll be able to address it in the next couple weeks, we can figure something else out in the interim.

Thank you again for all your help!

Hi @Taylor_Cohen, for clarification, are you saying your apostrophe’s are not getting imported or are being transformed to a different character after import?

1 Like

Hi @TonyC the apostrophes are being imported as those different characters after import

@TonyC sorry it may have been clear but upon reading my response back it also might not have been - the apostrophes are in fact being transformed after import, to use your wording

Hi @TonyC and @Marie checking in to see if there’s been any progress here. Still not a huge hassle, but it does happen on any import we have that includes apostrophes.

Hi @Taylor_Cohen, just wanted to follow up that we’re aware of this issue relating to apostrophes - this is something we plan on fixing though I don’t have an estimate on timing yet!

1 Like

@TonyC @Marie I’m hoping to use Asana as my new task management system for my two companies. I was very eager to start the import/conversion, however upon testing the import from my other provider this known issue is causing a huge headache across hundreds of tasks. As mentioned above, every apostrophe is being replaced by “’”. I have urgency around this to meet deadlines. Can you please let me know when this bug will be fixed? Happy to provide use cases.

  • List item

Example: We discussed some advanced tax planning that we'll be doing. Specifically, we'll be making …

Hi @Mark_Astrinos and thanks for bringing this up to my attention. I took another look into this bug and it looks our team wasn’t able to prioritize it yet. With that said, I’ve added your report to the bug and I’m closely following this task in Asana, so I’ll make sure to keep you posted as soon as I have an ETA.

I know there are some “Find and Replace” extensions you can install on your browser to help find all instances where “’” is replaced with “&#x27”. I’ve just tested one on my account, and it seems to be working well. I know this is far from being a solution, but I thought you might find it useful.

Again, so sorry for the trouble here. I’m hoping to be in touch soon with some good news!

Hi @Taylor_Cohen I seem to be having the same issue as you with the importing of apostrophes. Marie gave me a short term work around (find and replace extension), but to be honest, I’m importing hundreds of tasks into about 50 different projects and this adds more time to my conversion project. I know it’s only been a few months, but from my experience in monitoring the forum, things take quite a long time to be addressed. What did your team end up doing? Thanks for all your thoughtful commentary that helps others!

Hi @Mark_Astrinos, unfortunately, we have mostly just dealt with this issue as is. I informed my team, and we decided it was more of a superficial annoyance for now rather than something to spend time finding a work around for. We also try and rid our import of apostrophes before importing - I haven’t used the extension you and Marie are talking about, but I would imagine find and replace is easier to do in the excel beforehand than with an extension. Sorry this isn’t much help! Let me know if your team figures out anything else.

@Taylor_Cohen thanks for the reply. There’s definitely something goofy going on with the coding, as I couldn’t even copy/paste a sample of the issue on this forum. Getting rid of apostrophes would be challenging as then all the text in our live(open) tasks that we’re importing wouldn’t read as well but I suspect dropping an apostrophe is better than those odd characters. Crazy that we have to make these tradeoffs. I’ll likely do a macro in excel to replace ’ with something else if asana can import that like " or `.

@Marie Thanks for being “on it” and for the suggestion. I’m guessing you can never provide time estimates of whether you think it’s a few weeks, months, or years, until they would be able to prioritize it? Given that it’s arleady been a few months my guess would be that this is low on priority which is fine. Just weighing “waiting” versus work around.