Google Drive File Picker


#1

Hi!

I am not sure if I am using it entirely correct, but the file picker for choosing a file from Google Drive seems broken? It doesn’t seem to take folder structure into account, but flattens out all folders and sub-folders into one flat (and subsequently unsearchable) structure. I am doing it wrong?


Don't prompt for which Google Account to use for every single file attachment
Google Drive File Picker Usability
#2

Sorry for the trouble here, @Jorgen_Andersson!

I just tested this out and it appears to be working properly on my end. This sounds like an issue that can be solved by troubleshooting with your browser. I don’t yet know the exact cause, but I’m confident that if you take the following steps, you will find a fix. Other customers have done so with success.

Please try each one; if none resolve your issue, feel free to let me know as this will be a great help in our investigation.

  1. Disable browser extensions/add-ons while using Asana. An incompatible browser extension is often the cause of problems like the app failing to load or buttons becoming unclickable. Learn more here: https://asana.com/guide/help/faq/browsers#gl-extensions

  2. Update your browser. This is a general best practice that will ensure you have the best experience with Asana possible. Learn more here: https://asana.com/guide/help/faq/browsers#gl-update

  3. Clear your browser’s history/cache/cookies. Learn more here: https://asana.com/guide/help/faq/browsers#gl-history

Once you’ve done this, reload and visit app.asana.com once more.

  1. Test for the issue on another supported browser to see if the problem is on the browser side or consistent across many browsers. I am not asking you to use Asana in a different browser forever. This is merely a test to help resolve your issue. Find more supported browsers here: https://asana.com/guide/help/faq/browsers

If you’ve already tried some of these, please still try the others. If your issue is not resolved, please let me know, and let me know which of the above you’ve tried, and we’ll troubleshoot further.


#3

Hi again,

so I recorded two videos showing the issue. The first one is in Chrome (and
since it’s Chrome it is the latest version by default) where I am running
in Incognito Mode, with all extensions turned off. You can see where I
first show my Google Drive from Google Drive, and after that I go to Asana
to attach a document form Google Drive. It has then already traversed all
folders and presents them in a flat structure, and the further I scroll
downwards, it keeps traversing all folders and presenting all files in a
flat structure.

The second video is me trying the same thing in Edge, and it is the same
behavior there, with the folder structure pre-traversed and presented flat,
and the more I scroll all files are also traversed and presented in a flat
structure.

So, I don’t believe this has to do with either extensions, browser cookies,
browser version nor even browser brand? Have you tried in a fresh Incognito
Mode Chrome, so that you are not running a cached version of Asana?

It seems consistent over both Chrome and Edge at least. I am running
Windows 10 Home 64-bit version.

Best regards, Jörgen Andersson

https://drive.google.com/a/jgtconsulting.com/file/d/0BxCYqcSW4ZerTU5Jb0FNdFJPVkU/view?usp=sharing
https://drive.google.com/a/jgtconsulting.com/file/d/0BxCYqcSW4ZerR181WnRpZmJzSDA/view?usp=sharing


#4

Thanks for the update! Looking forward to watching the screencasts. I’ve requested access to both.


#5

Hi @Jorgen_Andersson!

Thanks for your patience. I had a chance to review your screencasts and I have to be honest, I’m not sure what the issue is. I think it’d be best if we continued this conversation via Asana Support. I’ll file a bug and reach out to you via email.

Thanks again for the follow-up and helpful screencasts!


#6

Hi @Jorgen_Andersson

I have exactly the same issue as the one you’re describing.
Have you been able to fix this ?

I hope there is a solution because I agree with you it’s unsearchable.

Thank you
Julien


#7

Hi @Jorgen_Andersson ,

Echoing the comment above from @Julien_RENAUD, I also have exactly the same issue in both Chrome and Safari. Have you had any joy in getting this fixed?

Thanks

James


#8

The Google Drive file picker is hard to use and not useful. It just shows all the folders without any structure. I can search for files, but I’d have to know the exact name, otherwise it cannot be found on the file picker. Please use such file picker that I can see the folder structure, navigate through the Drive folder structure. Also, Slack, for example, has a better file picker even though it shows only recent files. At least it shows the files.

Best,
Oskari


#9

I too am having this issue as described above by Jorgen_Anderson. No matter how I sort I can’t get to the files or documents. Adding a search filter of “documents” doesn’t help either.


#10

I just want to piggy-back on the other comments. I have the same issue. In a task I go to “ATTACH A FILE” >> “Google Drive” to get to Google Drive’s “Select a File” pop-up.
That produces a laundry list of files with no folder structure. It also doesn’t appear to load all of my files, such as files that my team has shared with me. When I use the search feature and type words that I know are in the name of the file I am looking for, the file often doesn’t show in the results. This has been disappointing because all of my files are in google drive and I want them to be easy to access from both the Task and the “Files” tab for the project.

For the moment I have given up on the Task Attachment feature and am just pasting google drive file links into the task descriptions.

Thanks to @Jorgen_Andersson for raising this issue and to @Terri_Burden and the Asana team for responding to this thread and their ongoing work on this. I look forward to its resolution, it will be such a huge help to me and my team!

-Taylor


#11

Same here. We are using gsuite with Team Drives. No drives are visible in the Google drive attachment popup. Just a long list of files and folders mixed up.


#12

Same issue for me. I want to add a file that everyone in the organisation has access to but it doesn’t appear on the search. Is this because it is in a Team Drive?


#13

So this is an issue with development and the team at Asana. The Google Drive Picker can be set up to show different views (https://developers.google.com/picker/docs/#otherviews) and one option is to show a file structure as it is set up in Google Drive: google.picker.​ViewId.DOCS.

This is a critical feature for usability, and I am very interested in seeing it resolved!


#14

By “with development” I mean for development. Sorry!


#15

Another ‘Me too’.

Asana’s Google Drive integration - or rather the UI for it is very poor. It’s particularly jarring because Asana UI is generally very good, and yet this aspect is almost unusable compared to any other external tool I’ve used with Google Drive integration.

It starts with requiring me to pick which google account every time, whereas most tools establish a link to a particular cloud store. What’s particularly galling is that I log into Asana with a Google Login, but Asana doesn’t use the standard Google account hinting to speed login into the corresponding Google Drive.

And then the file picker just seems to list a random collection of deeply nested folders and files, with no regard for the nice, considered, organised folder structure I have.


#16

This may help - screenshots of

  1. My Google Drive web interface, showing the folder structure,
  2. A random Google Drive picker from another tool, behaving much as you would expect
  3. A screenshot of the Google Drive picker from Asana, listing a whole lot of Random folders

Google Drive native web interface:

.
.

Typical/normal/proper integrated SaaS file picker

observe shows my top-level folders only, in correct order


.
.

Asana file picker

observe random folders and files seeming exhumed from the nested depths of My Drive, Team Drives, things that happened to be shared with me … etc… etc…


#17

So I’m having the same problem.
Unless my memory fails me, there once was a proper implementation of the Google Drive file picker and I miss it!
@Terri_Burden Is this current implementation working as intended? If so could you guys give users the option to change it to what @Justin_Maxwell described in such detail?