Filter only my tasks doesn't include subtasks

In my projects, when I use the “Filter > My Tasks Only”, Asana don’t include my subtasks assigned to me.


Yes, this is a feature of Asana’s design decisions. It takes 100% of new users by surprise. We all expect that the Subtasks of Task A in the Panda project will also be in the Panda project. But Subtasks do NOT automatically belong to the project of their parent.

It is possible to add Subtasks to the project of their parent task (or any random project, for that matter). I don’t do that myself, as it has an unwanted side effect of causing the Subtasks to then clutter up Timelines and List Views…you see them both when expanding Parent Tasks, and as individual items.

I recommend you search to see more discussion about how to cope with this. Good luck!

1 Like

Agree with @Stephanie_Oberg This is not as straightforward as one would want. If you are using Premium you could do an advance search for all tasks and subtasks thats assigned to you in a specific project. This will give you the desired list. Let me know if I should send a short How To video.

1 Like

Thanks @Paul_Grobler and @Stephanie_Oberg

@Paul_Grobler, I have a premium license, but I would not like to have as many reports (saved searches) as projects :frowning: , also I would like to see my tasks and subtasks organized in the slots / sections / phases of the project to have a better understanding of my role in the project.

I also try to use My Tasks view, but as @Stephanie_Oberg explained subtasks are not linked with each project, also in this view I have the same issue with the advanced search option (can not see the project roadmap).

@Stephanie_Oberg , I understand that I can expand the tasks to see the subtasks assigned to me, but to review each task of the project to find my subtasks takes a lot of time, I think this is not a good option :frowning: .

Maybe the workaround will be to not combine responsibles in the same task or to not use subtasks at all :hushed:


and this is why we chose not to use subtasks. I hate the way Asana handles them.


Thanks for your comment @Shirlyn_Adkins

This topic was automatically closed after 6 days. New replies are no longer allowed.