Enter pressed doesn't add a new project anymore



When adding a task to more than 1 project, it used to be easy by using [Tab+p] and then just to add a new project if the task was already in a project. So this could be done without the use of a mouse. Now we need to click the “+” next to the project to add more projects instead. This delays the task significantly and it’s strange that it is changed, or did anything else interfere?


Hi @Mike_Zhu Are you still able to reproduce this problem? I’ve just tried on my end, and I’m able to add a task to another project with the “Tab+P” shortcut. Keep me posted! :slight_smile:


I’ve found that there are times when Tab+P doesn’t work, maybe you’re having the same thing. When this happens I can click in the task pane with the mouse and it starts working again.

I’m not sure what causes it, and it somewhat defeats the purpose of having the shortcut, but it’s still easier to click the pane and then hit Tab+P than clicking on a little button.


Hi @RyanE, if you manage to find out what triggers this issue or how to reproduce it, please let me know and I’ll be more than happy to escalate a bug on your behalf! Unfortunately I can’t seem to be able to reproduce it on my end!


Well it’s not the Tab+P that is the issue, it is the Enter pressed after you do a Tab+P, and maybe related to the issue for @RyanE . To explain a bit more: When a task is already is in more / less than 1 project (so 0 or 2+) , Tab+P will go to “add to project” mode, but if the task is only in 1 project, tab+p goes to “replace (edit) current project” mode. Which is fine, but then it used to react to an as if you want to add more projects, like when it’s in “add project”-mode, but now it just does nothing and stays in the “edit”-mode so I can’t add more projects anymore. So for every task that is in exact 1 project already, I can’t use Tab+p anymore as a shortcut to add more projects to the task. And in my use case, I get it a lot, because someone else adds it to a “inbox” project and I’m responsible to delegate it further into projects for others


Mike, I think if you hit Tab when you’re starting with one project and adding more, it’ll keep that project and go to the next line to let you add another, which is different behavior for the 0 or >1 version of the control that puts you straight into an add state with nothing on the line already.

It can be difficult working with projects from the keyboard as based on the different modes you have to switch between using arrow keys, tab, and enter.

Here are some screenshots to demonstrate the control’s different behaviors:

  1. Edit mode (occurs with 1 project already in the task, hit Tab to keep the listed project and add another):
  2. Add mode (occurs with >1 projects already in the task, hit Enter after typing in the project):
  3. Add mode also occurs with 0 projects in task
    I didn’t do a screenshot because it looks just like Add Mode above, minus the projects already existing. I like this example for showing the inconsistency of the form because you can’t add the 2nd project without having to switch methods before going back to the first.


Hi @Marie, I figured out the scenario that causes TAB+P to not work. It’s… specific. These are the steps and requirements to reproduce it:


  • Must be a board project


  1. Create a board project
  2. Add a column to the board
  3. Add a task to the board
  4. Open the task
  5. Add a subtask to the opened task
  6. Go into the subtask
  7. Hit Tab+P

Nothing happens.

I’m running into this mostly when I use a set of template processes I created. I have a project called Templates with various processes I’ve created ahead of time with the relevant tasks and subtasks. When I copy one to a new project I often assign subtasks to particular projects (I don’t default them in the template because then those template tasks show up in their respective projects). Hopefully that makes sense.

Feel free to move this wherever it makes the most sense.


Thanks for (1), that’s the workaround I was looking for, I used to do that with but can’t pin point since when that stopped working, because I never used Tab for that function :grinning: I would still like the behaviour to be the same though, but at least I have a workaround


Thank you so much @RyanE! I’ve escalated the issue to our Development Team. I’ll make sure to keep you posted as soon as I have an update!


same here. is really not working (anymore)


For me the TAB-P does not work ( in both Board & normal mode) .

If I hit TAB-P and the task is allready assigned to anther project TAB-P Selects/overwrites the current project instead of Adding one (+)


Hi @Edwin_Rooijakkers,

I tried to explain the different ways TAB+P works based on the number of projects already in the task above. Here’s a link to the specific post:

Basically, if you have one project on a task, what you’re describing is what happens and you need to hit TAB instead of ENTER to add a 2nd project.

Hope that helps.


It helps a small bit but it does not make sense
TAB P for adding project to a Task is The best way no mather if a project is allready added or not .


@RyanE, Thanks for the tip about using TAB after TAB-P to add the task to a second project. @Marie, a related issue to consider pointing out to the development team is that TAB-P behaves differently than its counterpart, Add to Project, in the More Actions menu. This is with just one project already in the task (have not tried with multiple). Selecting Add to Project adds the task to a second project whereas TAB-P overwrites the current project, except when TAB is used to move the focus as @RyanE described.