Enable Recurring Tasks to Trigger Rules

Briefly describe (1-2 sentences) the bug you’re experiencing:

  • Reccurring tasks not responding to rules

Steps to reproduce:

  • Add sections ToDo and Done in My Tasks (I’m guessing other projects behave the same, but I’ve seen it in My Tasks)
  • Make recurring task in section ToDo
  • Add rule to move completed tasks to section “Done”

Now the task gets moved to “Done” and the new occurence is created in the same section.

Even when I make another rule that tries to catch the new task being created and moving it to the right section, the rule seems to ignore the new task and it will always stay in Done.

Browser version:
Desktop App

What version of Asana are you using (Personal, Starter, Advanced, Enterprise, Enterprise+, Premium, Business or legacy Enterprise)?
Enterprise

Upload screenshots below:

@Jan-Rienk - I think this is less a bug and more a known design choice/issue: instances of recurring task do not trigger the “task added to this project/my tasks” rules as we might expect. There are a few request threads on this, including this one:

I agree that it really doesn’t compute for me why this trigger would not be met. I believe Flowsana does view these are newly created/added tasks if you happen to use it.

HI @Jan-Rienk sorry for the trouble. @Stephen_Li is correct, and this is a limitation rather than a bug.

At this time, rules will only work when you manually trigger them or if another rule triggers them. For example, when you mark a recurring task complete, Asana will automatically duplicate the task and add it to your My Tasks. If you have a rule stating “Task added to My Tasks → Action XYZ,” this action will not be triggered because:

  • You are not manually adding this task to your My Tasks
  • Another rule is not adding this task to your My Tasks; it is simply a task duplication.

Regarding the first part of your question, please note that every new task added to your My Tasks is automatically added to the “Recently Assigned” section, which is also expected product behavior.

You can adjust this via the Hacks tab of your profile settings to add a recurring task into the last section of your My Tasks instead of Recently Assigned . Therefore, you can place any desired section last to make sure the new tasks will land there, however, if your desired section is not placed last in your view, this won’t work.

@Stephen_Li @Vanessa_N

If this is intended, then I would question the sense of the intent.

Yes I can see hat it might be tricky technically. But from a user perspective it’s a bug.

  • It’s a new task
  • It’s being added to My Tasks

The rule trigger is. “When Task is added to My Tasks”

Rule doesn’t run.

I get that you’re not going to treat/fix this as a bug if development calls it intended behaviour, but I think I should at least share my perspective.

Just FYI @Jan-Rienk, rules in our Flowsana integration do trigger on new instances of recurring tasks. :wink:

3 Likes

Hi @Jan-Rienk, I completely understand your point, and appreciate your feedback. I have already filed a feedback report for this topic, but I’ll also move this thread to our Product Feedback section so other users can upvote this request.

1 Like

This topic was automatically closed 16 days after the last reply. New replies are no longer allowed.

@Vanessa_N I think the rule closing this had to do with the bug category this post used to live. So I opened it again. (And de-selected the solution as I don’t consider it solved)

Are there any workarounds that could help?

I have a custom field called “progress” that helps me track progress with the task.

The rule that sets the field value of a new task to “unbegun” works very nicely.
The rule that sets the field to “complete” when the task is Marked Completed also works really well.
But any recurring task comes back into the project with “progress = complete”.
I thought a simple solution was going to be
When: Task is added to this project → Do this: Set Progress to Unbegun

or even
When: Task is added to this project → Check if: Progress is set to Complete → Do this: Set Progress to Unbegun

But neither have any effect.
Hoping you have some advice about how to get recurring tasks to be parsed by rules. Many thanks :slight_smile:

1 Like