Email features not working



  1. The ‘Email to My Tasks’ feature isn’t working for me. Emailing to individual project addresses works fine but I get no result from trying to send to My Tasks using

  2. In the past I have been able to forward emails containing attachments directly to projects, and have the attachment be added along with it automatically. I’ve noticed this week that isn’t happening anymore, attachments are not being added.

Any help would be much appreciated - this functionality is a big selling point for Asana at my workplace as we try and move away from email for managing workflows.



Hi Zane. Glad to know this feature is helpful for your team! We’ll want to know if this is a bug or not. Has emailing to worked for you in the past?


Thanks for the feedback, @Zane_Love. I have a few thoughts to build on Alexis’s question.

For #1, I would recommend checking your email set up on the “From Email” tab of your profile settings, This will determine which organization your tasks will be forwarded to using the address. Can you confirm this is set up correctly?

For #2, is there a particular type of file format that is no longer working? Can you try a few types of attachments to see if any of them are coming across? There is a file size limit on individual attachments, so I wonder if this may be a cause by affecting larger file types.


Hi Kaitie

Thanks for your response. I will check re: #1 and advise. Re: #2, the behavior is quite erratic – after posting this, I was able to successfully forward an email and attachment to a project, but I tried again just now, and had results as follows…

This is what was sent (that ‘To:’ address resolves to the correct Project in Asana)




Sorry for the multiple replies, I’m only able to send one image per post.

I just tested attaching the same document directly in the Asana project and there was no problem so it certainly seems to be a transit issue. Any ideas?


Hi Alexis

Thanks for your response. The address has never worked for me. Never had an issue with the project-specific ones though.



Update…fixed the issue, it was my workspace settings, set to send emails to my personal projects rather than organisation.