Dragging items in top section of list view in Android reloads

Briefly describe (1-2 sentences) the Bug you’re experiencing:

In Android, when I drag items down in a custom top section of list view, it reloads the page. This is typical for Android UX, but it prevents being able to reorder items in the top section. However, if I drag things in lower sections first, then come back to drag things in the top section, it starts to work.

Steps to reproduce:

  • Go to list view.
  • Have at least 2 custom sections.
  • Have at least 3 items per section.
  • Drag items in top section to reorder.
  • See that Asana reloads instead of reloading dragged item.
  • Problem temporarily goes away if you first drag things in lower section.

Browser version:

  • App version 6.64.6

Upload screenshots below:

1 Like

Hi @Henry_Wallace,
Welcome to the Asana Community Forum!
You have to touch & hold the item for 0.3 seconds then try to drag it up or down!
If your issue still exists clear the cache of the app and try again!

2 Likes

Hi @Henry_Wallace, welcome to the Asana Community Forum!

Adding to what @Soumyadeep_Mandal mentioned, I also recommend you uninstalling and reinstalling the Asana app. This will also ensure you have the latest available version :slight_smile:

I’ve tried both longer/0.3 presses, and reinstalling. Though it still reloads page instead of reordering most of the time. About 1/10 of the time it does reorder the top item after click hold drag, but I can’t descern what I’m doing differently to make it work.

FWIW I also found a few other similar comments in the android play store comments, to see if it’s was just me.

And it also appears to be a broader problem to not just the top items. But things in 4th or 5th, albeit less often.

1 Like

Hi @Henry_Wallace,
I just tested by myself on my account with multiple projects and also with one of my friends’ devices and It’s working fine on my side & my friends’ side.
There might be a problem with your device or the way you are doing it.
Please try again, touch & hold the item for 1 or 2 seconds then try to drag it up or down!
It should be working fine.
and also check if the comment from play store is recently posted or posted many days ago.

1 Like

@Henry_Wallace if the issue persists, I recommend you to contact our support team: How to contact our Support Team ✉ and share the URL of this thread so they can help you investigate this further!

Curiously I’ve tried all the above, but still I cannot drag consistently for top items. I’ll follow up with the support team, thanks!