Drag Subtask back to Project removes task


When I drag a sub-task of Project A back to the main Project A list, it provides confirmation dialog (lower left) that it was successful. However, the task is deleted (not added back to task list), and seems gone forever unless I undo in time.

Maybe someone can confirm for me?


Hi @Zak_F

I just tried the same thing and it worked for me. Looks like it might be a bug.

If you go to https://asana.com/support you can contact support.


Ok, I’ll see if I can reproduce again with a new test project and on another Team. If it still has this issue, I’ll report the bug.


Ok, so this is working on a fresh, newly created set of tasks. It seems this bug might be related to the fact that all the previous tasks were imported via CloudPipes API (Smartsheet rows to Asana tasks), and were not assigned to or created by me, since it was an automated import. This seems to be the cause of my other reported issues also, so let it be known if you import via CloudPipes API, you’ll need to specify a user assignment to the tasks to avoid this and other issues.