Desktop app pegs CPU at 100% when offline

Briefly describe (1-2 sentences) the Bug you’re experiencing:

When my computer is offline, eg WiFi turned off, the desktop app uses 100% CPU. Seems like it’s busy-waiting on attempting to reconnect, or something similar. When I reconnect the network, it goes back to using only a reasonable amount of CPU.

Steps to reproduce:

  1. Run the desktop app.
  2. Disconnect network.
  3. Observe CPU usage.

I see this with v1.1.0 of the app, on macOS 11.4.

Thanks in advance!

Hi @snarfed,

The @Community_Managers can confirm but I don’t think this is a bug as the desktop app is not designed or intended to work offline.

1 Like

Definitely! I’m not expecting it to work offline, I’m just expecting to be able to leave it open without it chewing up an entire CPU.

Ah, OK, got it! Agreed then - that is indeed an issue if it pegs your CPU at 100% when you’re offline.

1 Like

Thanks for your report @snarfed! I’ve gone ahead and escalated this to our product team so we can investigate further. I’ll keep you posted!

2 Likes

Happens in the app on Mac also when connected to the internet. Soon after running the app, it takes 100% CPU and no longer releases it. Thus, the fans turn on high and the battery is empty in no time.
Happens on more than one Mac in our Network in Asana version 1.2.0 on MacOS 10.14.6.

Hi all :wave:t2:

Thanks for your patience here! Our Product team has confirmed that this should be fixed :slight_smile: Please let me know if you’re still running into issues!