Date Picker should be stable on the screen when scrolling through months

productivity
tasks

#1

When I’m setting the due-date on sub-tasks, there’s no option to type in a date; I have to select the date using the pop-up calendar. Ability to type a date would be nice. But the calendar has a problem in that when scrolling several months into the future, I need to click the right arrow 5 or 6 times quickly but the scroll arrow moves around on the screen whenever a month needs to display 6 weeks rather than 5. This means that when I’m clicking rapidly the calendar will move under my mouse and either deselect the task or miss the button.


Calendar moving around when selecting due date. Frustrating!
Change a due date on the task description (left part)
#2

Hi @Ben_Flemming

What are Browsers etc are you using because I have just tried and I can type the due date directly into the field without using the Date Picker. As per below;

Oct-08-2018%2020-44-45

Jason.


#3

Right, the date picker works tasks, I’m finding this issue with SubTasks.


#4

@Ben_Flemming Oh okay Ben haven’t noticed that before will have to check it out

Jason.


#5

@Ben_Flemming I have mucked around with Sub Tasks as well and I don’t have the problem. For me the Sub Tasks behave the same as Tasks. Are other people in your team experiencing the same issue? and Have you tried another browser?
Might be worth contacting support.


#6

I can reproduce this behavior. @Jason_Woods, I suspect you are looking in the wrong place. There appear to be 2 date selection interfaces. And the one you get depends on where it’s being selected from.

  • “Full” date selection
    • You can manually enter the date.
    • The calendar doesn’t shift based on the number of weeks in the month.
    • Presented from
      • The Task panel.
      • The Progress view.
  • “Limited” date selection
    • You can not manually enter the date.
    • The calendar does shift based on the number of weeks in the month.
    • Presented from
      • The Task list when changing a Task’s due date
        • Sidenote, you can change the due date from the Task list but you can’t set the date from the Task list.
      • The Subtask list within the Task panel when setting a due date.

#7

Ahhh . Thanks @Vince_Mustachio. Didn’t even think about the date from the list pane… Agree with @Ben_Flemming it would be very useful to be able to end the date directly. Will be voting for this…

Jason…


#8

Hello all,
when you want to update a due date directly from the task (on left part of the screen), it is not so convenient as the calendar is “moving” because of the number of days of the month.

Is there an update planned on this?

Mat


#9

When it rains it pours. Someone else just noticed this behavior and posted a similar topic.

@Marie, could you merge please.


#10

Bonjour @Mathieu_Sterckeman :wave:t3: and thanks for your feedback!

As @Vince_Mustachio mentioned in his comment, we already have a thread on this topic, so I’ve gone ahead and merged your post with this main thread! Hope that’s ok!

PS: Just in case you missed it, we also have a French speaking Forum :slight_smile:


#11

I think it would also be helpful to be able to remove a subtask’s due date from list view, without needing to go down into that subtask’s notes and comments.
00%20AM

We sometimes have a project go on hold, where all the subtasks need to remain for later use, but all the due dates need to be removed.


#12

+1 here to fix. Was literally just talking to a colleague about this annoying behavior today.


#13

I’m working a lot on the calendar view of Asana. Most of the time I add a task using the “New” button on the top right. I almost always add a due date in my tasks. If it’s something for the future I probably get frustrated with the calendar jumping around.

I have made a screencast to showcase this (https://www.dropbox.com/s/ywfvdzhv084dtn8/calendar_jumps.mov?dl=0) but let me also add the steps here

  1. Click “+ New” and select Task
  2. Enter task title and details on the pop up task editor
  3. Click on the calendar icon to set a due date. In the example here I’m on December 2018 and I want to set a due date for February 2019.
  4. I click the “>” icon to go to the next month. Now January 2019 is smaller and if I click again without moving my mouse the calendar is lost! So to actually go to February 2018 I need to click “>”, move my mouse, click “>” again. The same happens if I go the other way (i.e. click “<”) or for other months.

I would expect much more attention to detail from Asana on such fundamental workflows.


#14

Thanks for your feedback and apologies for the trouble! I’ve gone ahead and escalated the issue to our Development Team; I’ll be in touch as soon as I have some update. Thank you so much for your patience and your help, really appreciate it!