Cursor "lost" at start of a line of text when an emoji is the first character

Briefly describe (1-2 sentences) the Bug you’re experiencing: When moving the cursor with the arrow keys in a task description, I discovered that “arrowing all the way to the left” will cause the cursor to disappear once the cursor passes an emoji at the front. Arrowing back to the right does not bring it into view.

Steps to reproduce:

  1. Create a new task with an arbitrary name
  2. Paste this into the description: “:slightly_smiling_face:test”
  3. IMPORTANT: Click into another task and then re-enter the task (this reloads the emoji, discarding the OS display format and showing the icon as Asana chooses to load it)
  4. Click at the right end of the description text and “arrow key left” to the front of the string.
  5. Attempt to arrow key back to the right.

Browser version: Bug exists on the Windows Asana Desktop App, not the browser.

What version of Asana are you using (Basic/Premium/Business/Enterprise)? Basic

Upload screenshots below:
Cursor to the right of the emoji
Cursor to the right of the emoji

Cursor to the left of the emoji
Cursor to the left of the emoji - it has disappeared and arrow key right will not bring it back

Hi @Paul.Harren, sorry for the trouble. I’ve been able to replicate this issue on the MacOS app as well, so I’ve escalated the case to our Developers. Thank you for reporting!

Thank you @Vanessa_N !

1 Like

Hello @Vanessa_N ,

At this time, can I assume a fix will eventually make it’s way to an Asana release?

Thank you,
Paul

Hi @Paul.Harren, unfortunately the Developers don’t have an ETA to share yet. But they’ve acknowledged the issue and it’s on their list to be fixed. Once I have any updates I’ll share here in the Forum.

1 Like