Copying project - wheels spin but nothing happens!


I set up a project and will be using it as a template. I click on “Copy Project…” give it a new name, and submit. A message pops up with the new project name and says it is being created. After several minutes, the message changes to say it is taking longer than usual and I will receive an email with a link once the project is ready. I never receive the email. It’s been an hour since I first created a copy of the project but nothing shows up in Asana and I have no email telling me it failed or succeeded. I’ve tried this multiple times and keep getting the same message.

My project is 61 lines long. I have four users in my organization but none of the tasks are assigned to individuals. There are probably six attachments and a few links. In other words, this is not a complicated project.

How does ASANA have so many large users successfully doing this when a basic feature doesn’t work? It’s been a year since I ran into this problem and it still exists today. Am I using the wrong browser? Is it because I have a free account? What’s going on?!?


It’s been 15 minutes so far and the wheel is still spinning…


That happened to me yesterday and there was a message that an email would be sent when completed. Not sure I ever got it.


I never received an email. However, I went back a few hours later and discovered the checklists were there. I tried it with a different browser and got the same result. I turned off my pop-up blocker and got the same result. I have no idea what is causing it.


Yeah I get that bit as well. I have created a standard Meeting Project that I copy all the time. The project seems to create fine in under a minute but for some reason the session you are in doesn’t recognise it. So I don’t worry about waiting for the Copying to stop I just do a search for the project or got to my Reference Project which has a link to all my Meeting Projects.


I rarely copy projects, but we have a lot of task templates that we copy every day. The new task is created in about 5-10 seconds, but the “taking longer than usual” pop-up never goes away until I click the X in the corner.


Sorry to hear you’re experiencing this, all! This sounds like it’s related to general Asana performance. This is something the team is super focused on. So focused, in fact, that we’ve written about it on our blog. We understand how challenging slow performance can be. Genuinely we do, since we use Asana for our work all day every day. So as time goes on we hope that you’ll be seeing less and less of these types of issues.

Here’s our most recent blog post about performance updates.

And we’d love for you to help us make Asana faster. Please tell us about how you work in this survey so we can cater the update to your needs. Thank you for your input!

@Nathan_Gesner It seems like that could have been a one-off issue - could you double check that this is/isn’t still happening when you ry to copy projects? Are you able to find a copy of a project when you search for it? Please confirm and we can determine if we need to file a bug report on this. Thanks!


I went back to Asana today and attempted to copy another project. It worked within less than ten seconds. Maybe yesterday was just a glitch.


That’s good news, Nathan! Thanks for letting us know.