Column resizing is broken on table-view

Briefly describe (1-2 sentences) the Bug you’re experiencing:

Resizing columns causes wrong columns to resize and this action cannot be undone / resetted (indefinitely eats first columns visible-space)

Steps to reproduce:

Please see attached GIF-animation. Basically resize any columns and try to undo that resizing later by trying to shrink columns.

Browser version:

Chrome, latest stable

Upload screenshots below:

Hi @Janne_Lepola :wave:t5: Welcome to the Forum!

Thank you for taking time to report this issue and for the GIF attached. I have tried on my end and it seems to work fine for me. In order to investigate this further would you mind testing the following steps:

  • Are you experiencing this behaviour with a different browser?
  • Are you able to reproduce it while using an incognito windows?
  • Can you please clear your cache and cookies and test it again?

Thank you for your help Janne! Looking forward to your reply!

I tried incognito on Chrome and the problem still exists – Whenever shrinking any other column but the first one it causes first column to shrink, not the intended one.

The problem does not exist on Edge and Firefox. Precise version of my Chrome is 80.0.3987.132 .

Thank you for the quick follow-up @Janne_Lepola and apologies for the delay in responding.

I’m going to file a task for the Team to investigate this behaviour but before I do that, I just need to confirm if you have tried to clear your cache and cookies? Additionally: can you also update your browser to the last version to see if the issue persists?

Thank you Janne! Looking forward to your reply!

Updated and cleared caches. Still broken.

Apparently there is some strange logic on this. I found a way to shrink first column back, but it’s not intuitive. I tried to visualize this behaviour more clearly, please see the attachment. If
you didn’t get this GIF-animation please let me know (answered by email).

Thank you for trying the troubleshooting steps and for the GIF Janne!

I’ve gone ahead and filed the task for the Team to investigate this behaviour and I’ll keep you posted as soon as I have an update from them.

Thank you for your collaboration and patience!

Hi @Janne_Lepola :wave:t5:

I got an update from our Development Team who has confirmed this is not a bug but actually the current behaviour as currently the way the columns resize may vary depending on the number of columns displayed in the project, on the horizontal scroll bar (whether is available or not) and a few other variables!

Thank you for taking time to flag this in the Forum! I’m marking this as resolved but please let me know if there is anything else I can help you with! Have a great Thursday!