Cannot add an email to my profile as a Google SSO user

I sign in with Google SSO. The documentation suggests that: If you use the Login with Google feature, you will instead be required to verify your Google account. A popup window will appear to log into Google, enter the credentials for the email address currently associated to your Asana account to initiate the process.

However, the popup does not appear, leaving me with a password prompt. I do not have an Asana password.

Steps to reproduce:
From a Google SSO authenticating account,
go to My Profile Settings

  • Add new email

Browser version:

HI @Chris_Hagan and thanks for reaching out.

From what I can see, Google SSO isn’t required in your Organisation, which means you can use it, but you don’t have to! Either way, you should be able to add a new email via Google SSO. I suspect your browser might be blocking the pop-up window, so if you haven’t yet, take a look at your settings. If this doesn’t help, you can click on “Forgot my password”, and from there you will be able to create a new password to log into your account. You can then follow the regular process (outlined here) to add another email. If this fails too, please reach out to our support team who should be able to assist you further with this. I honestly don’t believe this is a bug, but certainly something we need to assist you with! Hope this helps :slight_smile: