Asana Portfolio - Google Sheets redirect failed, could not execute app script

Hi all,

I tried to export my portfolio to google sheet but it keep showing:

Error

Google Sheets redirect failed, could not execute app script

Even i tried to match all the projects with existing portfolio that i can export to google sheet, but still not working.

please help me. thanks a lot!

3 Likes

Hi @Fransisca, welcome to the Asana Community Forum :wave:

I have tested this on my end and have been able to export a Portfolio to Google sheets with no issues.

I’ve gone ahead and escalated this to our Product team.

I’ll let you know as soon as I have an update!

Hi @Rebecca_McGrath

Thanks for you response. Yeah, thats why im confuse because i only can export that one particular portfolio, while i need to export the others.

Really appreciate your help, looking forward to the update. Thanks!

I’m also running into this! Was trying to export a portfolio for the first time and got that error.

Ideally, I want to do that through Google Sheets in Box, but I just wanted to see what I could even do with it.

I recently came across this feature for using Google Sheets with Asana for reporting that would be extremely helpful for our teams. The one catch is that we migrated away from Google Drive and are now using Box for our file creation & storage.

Since Google sheets are part of Box, does anyone know if this would still work through there? When I export a portfolio to Google Sheets, it wants to do it through our old Drive (that is now archived) and I get an error that the script can’t execute.

Thanks!

Also if it helps, the error I get when trying to create the google sheet is “Google Sheets redirect failed, could not execute app script”

@Rebecca_McGrath I appreciate you looking into this, but my other post (is there a way to export to google sheets in Box, not in Drive) was separate than this main topic (bug with asana portfolios not exporting to google sheets).

Is there an update on either of these?

Thanks!

Hi @Rebecca_McGrath

any updates from the Product team regarding my issue? thanks before :slight_smile:

1 Like

Just adding that I am having the exact same issue

1 Like

Hi @Rebecca_McGrath

any updates from the Product team?

Thanks!

1 Like

I am also running into this error and can’t find any solution. Any updates to this recurring bug?

"### Error

Google Sheets redirect failed, could not execute app script"

1 Like

Hey @here,

There are two ways you can work around this, you can either export the portfolio, or project, as a CSV file then import that to Google Sheets or you can use an integration solution like Unito and create a dynamic report that will always be up to date. I suggest the latter if you are building reports with any sort of frequency. They went so far as to build a Sheets reporting template to make life even easier.

I hope that was in some way, shape or form useful.

Mine is saying the same when I try to export my portfolio. @ReidT I have one which already works fine so I know it is not my end and I don’t really want to work around it. There seems to be a bug or something

1 Like

Understandable, in all honesty I am not a dev so I wont be able to offer much insight into how to fix the issue.

You could try clearing your cache? That might offer some reprieve but like I said I haven’t been able to replicate the issue so my advice is limited.

Maybe some @ambforumleader can offer more input?

I am having the same issue

I’m also having this same issue. I can export other portfolio’s to google sheets with no problem. Can we please get an update Asana ?

Yup, still having the same issue.
Honestly the lack of response here from Asana employees is both concerning and disheartening, it’s been several weeks now

2 Likes

Hi folks, thanks for the reports here!

I just wanted to let you know that our Product team are still investigating this issue. As soon as we have any updates, I will let you know here :slight_smile:

Thanks for your patience!

1 Like