Asana + Jira Cloud Integration accessing wrong Jira Cloud site

Briefly describe (1-2 sentences) the Bug you’re experiencing: The Asana + Jira Cloud integration is using old Jira Cloud site, even though I select a new Jira Cloud site.

Steps to reproduce:

  • Create two Jira Cloud Sites
  • Add the first Jira Cloud site as an integration to Asana
  • Change the Jira Cloud sit to the second Jira Cloud site
  • Try to add a new Jira story - is still connecting to the old site

Browser version: Chrome

Upload screenshots below: Will not allow me to upload a screenshot as I am a “New User”

Hi @Sue_Van_Riper, welcome to the forum and sorry for the trouble here!

I’ve just created a task to our development team to investigate this further. I’ll let you know as soon as I have more details.

Let me know if you have any questions in the meantime!

Hi @Sue_Van_Riper, just a quick follow-up here to confirm some details!

  1. Can you please try attaching a screenshot with more details about the issue? I’ve made some changes and you should now have the option to upload attachments.

  2. Can you also confirm which Jira version you are using?

Go to the URL that you use to log in to your JIRA account:

  • If your URL has this structure: "(your organization name).atlassian.net”, then you are using JIRA Cloud
  • If your URL does NOT have this structure: "(your organization name).atlassian.net”, then you are using JIRA server which is currently not supported
  1. Please try to deauthorize form the integration and authorize it again:
  • Go to your JIRA Cloud site - https://.atlassian.net/
  • Click on your user avatar (located at the bottom-left of the screen)
  • Click on “Account settings” (you will be redirected to a new tab)
  • In Account settings, click on “Connected Apps”
  • Under the “Apps with access to your Atlassian account”, you will see “Asana for JIRA Cloud”
  • On the “Asana for JIRA Cloud” tile, click on “Revoke access”
  • Now try to attach or create a new JIRA issue file in Asana and you should be prompted to re-auth.

Looking forward to your reply!

I completed the steps you described to revoke access to Asana. This process worked and I am now able to connect to the appropriate Jira Cloud site.

Thank you for your help.

Sue

1 Like

I’m glad the issue is solved @Sue_Van_Riper! Feel free to reach out if you have any other questions!