Asana Extension

I’ve been trying to develop an extension that incorporates some of Asana’s features, and have been basing it on the default sample Asana extension that currently exists in the Chrome store. I have been running into issues with regards to responses being undefined - I am almost exactly emulating the code that the sample extension uses, but it isn’t working. I know that my workspace_id is 0, which is the default when there are no localOptions to load from - not sure if this has anything to do with it.

The response is only undefined when I call … );

Any help would be greatly appreciated!

I am very surprised your workspace id is 0. Workspace ids are unique among Asana workspaces and should be a very long number :thinking:

I think it’s because I haven’t been able to retrieve my workspaces. Essentially, I am trying to run the ServerModel method that retrieves workspace IDs and info from the server. Until I actually can get those IDs and cache them locally in storage, I have to resort to the default workspace ID 0. Does the workspace ID in the options for a call actually affect anything? Because if so, then it would be impossible for any Asana app that did not have any initial data to retrieve the very workspace IDs they require from the server, and I know that the REST API design is not that dumb.

Essentially, it’s definitely some other problem, but I just can’t figure out what. Does anybody know how the Asana extension requests from the API server on first use? What is the path - is it first ServerModel.options, then login, then me, then workspaces?

Hi - does anybody have any solutions or advice? Anybody worked with the Asana extension before?


I solved the issue! Just so future people know, it had to do with a background script that I didn’t know existed running onMessage to capture a sendMessage call.