Asana Ambassador application link does not work

Briefly describe (1-2 sentences) the Bug you’re experiencing: When I tried to apply to be an Asana Ambassador, the form would not submit and is also unsecured.

Steps to reproduce: Try to apply. PartnerStack

Browser version: Internet Explorer (it was the only browser that would support it, since the link is unsecured).

Upload screenshots below:

Hi @Richelle_Pittella and thanks for reaching out!

That does seem strange, I just tried the contact form with Chrome, and everything seems ok (my laptop is set up in French but the green message indicates that the connexion is secured.

Could you maybe try from another device or your phone for example? Could you also provide us with a screenshot of what you see?

Looking forward to your reply!

Looks like it worked on my phone. Thanks for your help!

1 Like

The link posted here is not the best link. I used it and was told to use this link instead - Loading... - Form by Asana

This topic was automatically closed after 3 days. New replies are no longer allowed.