A new way to write clearer, more detailed tasks

Hi guys!
I have been testing this task description and so far I’m in love with this!
Few questions from our clients side though.

  1. Seems like they can’t put the image nor youtube yet. Would this be available in the future?

  2. When we drag in an email by using (x@mail.asana.com & more), would the chart be shown as well? Right now, all charts come into Asana broken.

Very cool! I was wondering, how did you get that YouTube video preview in your Asana task? (Shown in the screenshot.) Simply writing down the link did not work for me. And in the new menu, there is no option to add an existing video (only to record one).

Edit: Ah, sorry, I just saw that this feature is only in the pipeline for now, not rolled out yet. It was a bit confusing for me then to already see it in the screenshot.

1 Like

Typically the users who are upset about something are the loudest ones ;-). Threads in forums never indicate the actual ratio of people satisfied with a new feature.

1 Like

OK - been using the feature and a couple of things (design wise) that annoy me.

  1. The spacing between the heading and the next paragraph creates a lot of distance and would what normally be a short description even longer. I like having a larger font to distinguish between a heading and the paragraph, but the line height spacing could do with adjusting. I often scan read and this makes it more difficult. Especially when you follow a template that is designed in a question format, eg: Who is this for? (answer) What is required? (answer) What resources do you need? (answer) etc.

  2. I know this is not part of markdown but you are missing a trick here - colour. Highlighting something with a different colour can bring important context/attention to important parts. Red, Green, Blue are definitely colours I would use frequently. The option to change the text colour would be enough.

Other than these 2 points, I am getting used to it and does not appear to get in the way of writing tasks.

6 Likes

Can someone explain how to paste text in the description’s new update WITHOUT each line now becoming a new draggable section. I have tried the following:

  • paste as plain text
  • CTRL + Shift + V
  • screaming at my pc

There’s got to be a way, right? If not, this is has gone beyond formatting. There is no way that Asana thinks that everyone needs a description to be an auto list with moveable sections every time we type into the description…right? Sometimes you need it, sometimes you don’t.

7 Likes

@Adia_Sabur,

I agree this is an issue.

But a workaround (yes, it’s a little extra work!) that I use is to use Ctrl+Shift+v in another tool, then copy that text and paste into the Asana description and you do get a single block.

For example, in a GMail compose window with multiple lines of text (separated by newlines):

  1. Copy those multiple lines of text
  2. Paste them with Ctrl+Shift+v elsewhere in the GMail compose window
  3. Copy those pasted lines
  4. Paste into Asana task description.

Hope that helps,

Larry

3 Likes

I absolutely HATE this change to the description field. I have been sending feedback on it as it’s just awful. I copy text from a word document into the description field and no matter what I do, it doesn’t paste without each line being a different paragraph/section.
Please put this back how it was or let us turn it off. Why ruin what wasn’t broken?!?!?

11 Likes

Or at least make it so that a paste will paste within a single paragraph/section.

3 Likes

What I would LOVE is the ability to embed images in-line within the description (or comments, for that matter).

When I need to provide context with screenshots or charts/graphs, I almost end up doing it as a series of comments or publish my thoughts in a word document and link/share that or (gasp!) send an email because I can’t have one long flowing message with everything embedded.

Even here in Asana’s forumns I can post an image in-line and comment above/below it.

image
Especially useful for adding captions

Minor formatting issues aside, I believe this is a step in the right direction.

5 Likes

I agree the new update makes Asana pretty much unusable, I now need to manually enter information using shift + enter for single space, which is a complete waste of time, since you can no longer copy and paste text without each line being a new paragraph. It is sad but I think it might be time to find a new management software.

3 Likes

Ever since this update has been pushed out, everything I type in the description is double spaced. So everything takes twice as much space. Can I undo the double spacing somehow? Thank you.

4 Likes

Seriously? So I guess we should only serve vanilla ice cream at stores then? Matt wants vanilla so everyone else shouldn’t get mint chocolate chip or cookies and cream, there should only be 1 selection on the aisle…

Just use what you want. This feature doesn’t get in the way of you using plain text formatting, as well as copying in plain text or copying this text out to a plain text editor, but that doesn’t mean that 1 person wanting plain text formatting should prevent others from using industry-standard markdown.

1 enter gets you 1 newline. Try copying out to any text editor… Your formatting is perfectly preserved, unlike what you say.

Yes, inside the description field, it visually looks different. They’re going in the same direction as every other modern application and adding more whitespace to pages, but it doesn’t impact the formatting as you’ve described. I do wish my life was as simple as yours though, to where shift+enter was so workflow-breaking that I felt like leaving a platform. On the other side of this coin, software teams have been avoiding communication inside of Asana for years due to the lack of support for code blocks, which this update doesn’t even go far enough to fix. We instead are constantly mapping and threading communication between other (reasonably modern) apps like Teams, Slack, Notion, etc. so that we can adequately communicate our formatted text and then reference that back to Asana, which has been wholly disorienting for people, and now I understand why, because even pressing 1 more key on your keyboard is a challenge that you can’t overcome in your day, despite that being a feature in chat clients and websites since at least 2008 as far as I can remember…

Personally, I hope they keep going. This is a great feature that leaves all of the existing functionality intact while adding more features for those of us who need them. I’m glad to see Asana leaving the early 2000’s. Now please please please add code block support, and find a good time to replicate this feature in the comments section.

1 Like

Wow dude, am I going to make your day. Next time you get confused at how your “paragraphs” (or really, newlines) move around, press Ctrl+z, and your text will be fixed right-away!

I can agree that there’s a bit too much whitespace. Other modern apps like Notion or Slack have similar object handling without putting an entire line plus its margins in between each line. Perhaps they could visually update the line spacing.

I’ve actually appreciated the reduction in screwing with the field sizes when clicking in and out of the description field though. Before, it would resize when I clicked in, which was disorienting to me. Now, it drops a cursor exactly where I click. I find this to be an improvement. I wouldn’t be opposed to them re-introducing some row highlighting though while editing.

Agreed! We need to be able to select an entire section of bullets, lines, etc. and move it above/below as desired. I’m working around this for now by selecting, cutting, and pasting.

I think this will just relocate the problem to people who use @, such as mentions (which is how Asana functions), or email addresses. I don’t have any problems typing this/that by either hitting escape before I’m done typing the second word or finishing the word and hitting space. Looks like Asana took that industry standard. When I type this/that in Asana, nothing happens because the / is not at the beginning of the line. When typed at the beginning of the line, like /this t, the 2nd t causes the command to be escaped. Hitting esc also exits the command mid-word, such as /para<esc>graph. Hope this helps!

Pressing Shift + Enter when adding new text lines will fix the double spacing issue

1 Like

Control Z doesn’t do anything. What’s it suppose to do?

I have this same problem. Nothing I’ve tried has worked.
Thanks